Page 2 of 2

Re: Where are the templates

PostPosted: Wed Jun 18, 2014 3:23 pm
by stevenamills
laplandz wrote:Sincere apologies Steve for not getting back to you sooner, been incredibly busy with blah blah....

I'm unsure about the registry entry, but i dont think you need that, when you create a junction it creates a file-system-level shortcut. they operate at a much "lower" level in the file system and silently redirect the access requests. its like digging a tunnel under the file system meaning its completely invisible to most user-ran programs.

did you delete/rename c:\ProgramData before making the junction? you can't have a junction with the same name as an already existing folder.

i think the steps would be:
boot to command prompt in recovery console
robocopy c:\programdata s:\programdata /e
ren c:\programdata-old,
mklink /j c:\ProgramData s:\ProgramData

think thats all thats needed. don't think you have to mess with registry (i didn't and its been working for over 6months now). when a program saves to c:\ProgramData, "NTFS" will automatically direct it to the s:\ProgramData with Windows not caring about it, hence the reason no registry alterations are needed.


Thanks so much for taking the time. It makes sense to remove the registry entry which I did and I'm sure that the junction is working as it should. Anything I do on the C Dr. is reflected on the S Dr. and vice versa.

I created the new directory and renamed the old directory in a fashion similar to what you suggested. I used a boot disk rather than the recovery console, but the result was the same.

Unfortunately, I still can't get the darn thing to work. Likewise, the data grab feature of D7 still has the same issue I have suffered with from the beginning. At this point I'm just saying the hell with it. There's something in my system that the program doesn't like and I can't find it. It removes a great deal of the functionality from dsupport in particular. Trying to create templates as intended is tedious and massively time-consuming. Apparently, I am the only one with the issue so I can only assume my system is at fault. Again, I thank you for your efforts and really wish it had worked.

Steve

Re: Where are the templates

PostPosted: Wed Jun 18, 2014 3:43 pm
by Nick
Out of curiosity, what is the environment variable for %systemdrive% and %systemroot% on your PC..? run the SET command at a console window to get the output.

Re: Where are the templates

PostPosted: Wed Jun 18, 2014 4:07 pm
by stevenamills
Standard stuff:

SystemDrive=C:
SystemRoot=C:\Windows


I don't know what else to check. Thanks for looking.

Steve

Re: Where are the templates

PostPosted: Thu Jun 19, 2014 11:15 am
by laplandz
i made a booboo in the last post, i should have said set the default path to that registry entry, not delete it, Windows will still need to know where programdata is (systempath or whatever the original settings were). let me know if you already did that.

Re: Where are the templates

PostPosted: Thu Jun 19, 2014 12:29 pm
by stevenamills
laplandz wrote:i made a booboo in the last post, i should have said set the default path to that registry entry, not delete it, Windows will still need to know where programdata is (systempath or whatever the original settings were). let me know if you already did that.


I did. Thanks for the folow-up.

Re: Where are the templates

PostPosted: Sun Jun 22, 2014 7:15 am
by Nick
Steven,

attached are 3 sample programs with different APIs for determining the location of the common appdata or programdata folder.

run them all, and tell me which ones are correct and which ones are incorrect.

thx

Re: Where are the templates

PostPosted: Mon Jun 23, 2014 11:52 am
by stevenamills
Nick,

Thanks for trying - I know this is my unique issue and you don't owe me this. I appreciate it.

Anyway, all three methods return:

C:\ProgramData

I don't know if this is good or bad?!?!?!?

Steve

Re: Where are the templates

PostPosted: Mon Jul 14, 2014 5:01 pm
by stevenamills
Nick,

Just curious if the preceding gave any clue?

Steve

Re: Where are the templates

PostPosted: Thu Jul 17, 2014 7:33 am
by Nick
no, I would have expected 2 of the 3 methods to fail for you, if not all three. this makes it even more of a mystery...

Re: Where are the templates

PostPosted: Thu Jan 29, 2015 7:17 pm
by stevenamills
I doubt this matters to anyone but me, since I'm the only one with the issue but the new or updated controls in the most recent version totally solved the long, long standing issue.

(I'm guessing it was the control, since D7II also works)