dSupportSuite Database

Discuss marketing/selling dSupportSuite and your monitoring/maintenance plans and strategies; also share your usage / configuration tips for dSupportSuite here, or ask the community for theirs.
Forum rules
1. Try to give more than you take, when possible.

Re: dSupportSuite Database

Postby csc » Tue Dec 16, 2014 4:27 pm

No it isn't, that seems to be based on the browser which is being used. I'm using FireFox and it's running fine for me. Not sure why the script wouldn't execute properly for you honestly. I just opened it up on my end and I noticed why you're having some problems, but I can't explain the dSupportSuite menu issue.

Delete all the rows in this sheet except for rows 1, 2 and 3. Then put the "New Install" emails in your inbox. The sheet will populate itself. You don't have the identity fields poplated and the maintenance days field is empty.
csc
 
Posts: 220
Joined: Fri Sep 20, 2013 12:18 am
Location: Toronto, ON

Re: dSupportSuite Database

Postby Techline2012 » Tue Dec 16, 2014 7:06 pm

Would you mind creating a fresh sheet for me?
Maybe I screwed something up, but I think starting from scratch would be ideal
Techline2012
 
Posts: 16
Joined: Mon Aug 18, 2014 4:23 pm

Re: dSupportSuite Database

Postby laplandz » Tue Dec 16, 2014 11:08 pm

Techline2012 wrote:Is it normal that every time I open the sheet it doesnt say DSupportSuite up top until I rerun onInstall and onOpen?


I use Chrome and had to setup a trigger to run the function OnOpen.

Sent from my ForwardXtreme using Tapatalk
.. ...
I can walk on water, but I can’t perform miracles.
laplandz
 
Posts: 299
Joined: Tue Nov 05, 2013 5:43 pm
Location: England

Re: dSupportSuite Database

Postby csc » Wed Dec 17, 2014 9:12 am

Techline2012 wrote:Would you mind creating a fresh sheet for me?
Maybe I screwed something up, but I think starting from scratch would be ideal


Yeah no problem. Make sure that you unarchive and unlabel your dSupportSuite emails if you need them to be picked up again.
csc
 
Posts: 220
Joined: Fri Sep 20, 2013 12:18 am
Location: Toronto, ON

Re: dSupportSuite Database

Postby nikolaosp » Thu Dec 18, 2014 4:15 pm

Hey Ray,

thanks for sharing the sheet with me but I have so many problems with it...
I followed the guidelines on how to customise the variables but I get "undefined" in the column labels (all of them) and #VALUE under all the Alert On columns. Obviously something is wrong on my end so I had the stupid idea of reverting the sheet to the one you sent me (previous version) unlabel all the emails and unarchive them but unfortunately it didn't populate itself. Also I think there is a problem with my labels. I have a Heartbeat top level label (created by your script I believe) which has all the heartbeat emails and 3 more labels like this:
dSupportSuite
|__Heartbeat (empty)
|__Maintenance (empty)
|__New Install (only this is populated with some new installs)

It is obvious I have screwed the whole thing up so, could I please request a new sheet? Sorry to be a pain...

Also is there a way to categorise the clients by which template they are registered with?

Thanks in advance,
nikolaosp
nikolaosp
 
Posts: 58
Joined: Tue Dec 03, 2013 1:44 pm

Re: dSupportSuite Database

Postby csc » Fri Dec 19, 2014 12:12 pm

Hey nikolaosp,

I reset your sheet, and noticed that I too don't get the dSupportSuite menu. Run the "onInstall" and "onOpen" commands to set the permissions correctly. Everything should work fine now.

Thanks,
Ray
csc
 
Posts: 220
Joined: Fri Sep 20, 2013 12:18 am
Location: Toronto, ON

Re: dSupportSuite Database

Postby nikolaosp » Sun Dec 21, 2014 6:16 am

Hey Ray,

just saw your message and run the onInstall and onOpen commands as you advised. Still cannot see the dsupportsuite menu and still have problems with dates not being recognised (?) correctly resulting to #VALUE or even more strangely to dates such as Sun, January 7th 1900 (!)... Also the labeling is wrong, some heartbeats go under dSupportSuite->Heartbeats and some under Heartbeats (top level label). I think I need to delete everything and start from scratch...

thanks for your help dude,
nikolaosp
nikolaosp
 
Posts: 58
Joined: Tue Dec 03, 2013 1:44 pm

Re: dSupportSuite Database

Postby csc » Sun Dec 21, 2014 9:11 am

@nikolaosp

1. You should check your permissions if the dSupportSuite menu does not appear. I've taken the time to confirm there is nothing wrong with the menu.
2. The dates on your sheet appear just fine. 0 - 0 = 1900 according to Google.
3. The labels in Gmail are all on you. If you don't like it, change them!

I don't think theres anything else I can do at this point, you've been reset back to the original template, and you'll have to figure it out from there! Read the first post over again in case you've been forgetting something.

Thanks,
Ray
csc
 
Posts: 220
Joined: Fri Sep 20, 2013 12:18 am
Location: Toronto, ON

Re: dSupportSuite Database

Postby nikolaosp » Mon Dec 22, 2014 4:01 pm

Hey Ray,

sorry to be a pain but I cannot make it work.

1) How do I check if the permissions is correct? When I opened the sheet for the first time it asked me and I replied to grant permissions as far as I can remember. The fact that it picks up some of the emails it must mean that it has the needed permissions. Correct?
2) OK with the dates, understood (i think). I saw a message on this thread saying "You did not define "maintenance_days". Define this variable (just type an integer into the right cell) to fix this error." Is this the problem I am facing? Probably since I haven't done that since I don't understand which cell you mean.
3) I have no problem with the labels that your sheet creates. I just think that having two Heartbeats labels one under dSupportSuite and another outside of this could tell us that we have a bug on the script code. It's not a matter of my personal preference, I'm just trying to give you more info to understand the situation I am facing for bug tracking purposes. Hope you didn't take it the wrong way.

Thanks for the reset but it still seems it's not working. I changed the language on google sheets and gmail to English US thinking that this might be the problem but still no luck. I unarchived the emails and even deleted the labels completely, run onInstall and onOpen again but no luck again!

So what I am finally asking if you could be so kind, mate, to delete this google sheet completely and share with me a new one so that I start from scratch with your help and guidance. We could even set up a remote session if you want...

Thanks in advance and again sorry to be the one breaking everybody's balls,
nikolaosp
nikolaosp
 
Posts: 58
Joined: Tue Dec 03, 2013 1:44 pm

Re: dSupportSuite Database

Postby csc » Tue Dec 23, 2014 4:36 pm

@nikolaosp

#1 - I'm not sure how to check these permissions honestly, but the alternative is that your computer isn't working properly. It's most likely the permissions and nothing on your machine.
#2 - You do have this problem. On my sheet I set the reminder days for each customer individually. Most customers are set to 8 days if that's what you're wondering. This is done automatically, you won't have this problem if you don't screw around with it. To fix this problem, we can revert to the original template.
#3 - I totally get where you're coming from. During development I was working out a few different bugs. The labels aren't something I do for you now, it's something you would have have to switch up yourself. If I "fixed" this on my end, your gmail inbox would only appear to get more complicated. Just specify the labels yourself in the script.

I looked into your Google Sheet and I have no idea how to do what you're asking. My sheet was not intended to support multiple languages, or multiple clients with the same Client ID. Make sure you have unique Client IDs and that your dSupportSuite package is emailing you in English. According to your google sheet, you have not received any maintenance or heartbeat emails (ever). Also, I get a permissions prompt every time I run "onInstall" and "onOpen" which I assume you already approved.

I set up a second sheet for you if you want to play around with it.
csc
 
Posts: 220
Joined: Fri Sep 20, 2013 12:18 am
Location: Toronto, ON

PreviousNext

Return to dSupportSuite Usage and Resale Tips & Strategies