bug or conflict with privatefirewall

These forums are retired and read-only.
Forum rules
These forums are retired and read-only.
For support, please visit https://www.d7xtech.com/support/

bug or conflict with privatefirewall

Postby refugi0 » Sun Jul 06, 2014 1:34 am

unhappy to report apparent dm conflict with pf which bumps xp off the internet :(
more unhappy in that it seems intermittent, ie, best I can tell does not always happen but when it does happen (& this started happening after I started using dm) it happens immediately after running dm. Short version is I looked up system errors on event log viewer and it shows dm started followed by improper shutdown of pf which then affected several items with the end result no WAN no IP. (I have the event error msgs but not sending in this post)
interestingly systemexplorer showed pfsvc was still running, so I want to see if I could fix this without a reboot, and nothing that I know to try would reconnect.
Eg, I stopped the pfsvc and restarted it, had no affect on connection.
stopped the net connection service and restarted that, no affect.
I tried ipconfig /release & then /renew and all it reports is "windows ip configuration"
I opened the network gui hit repair button and it said "failed to query tcp/ip settings of the connection. cannot proceed."
If in fact dm is conflicting with pfsvc, it's not really feasible to stop pfsvc to run dm. Very minor I'm sure with your other ongoing projects, but if you're interested I can send you the event log error msgs by pm or post here??
refugi0
 
Posts: 25
Joined: Sat Jan 04, 2014 5:31 pm

Re: bug or conflict with privatefirewall

Postby Nick » Sun Jul 06, 2014 10:50 am

tell me did you have any of the networking stuff checked or... actually a screen shot of your config page would be perfect so I can see exactly what you had going on.

sure just post the log text for the events in question. I can't imagine what could do what you describe at all, being there pretty much isn't anything but deleting temp files unless you did the networking stuff maybe, but perhaps the logs will change my opinion.

I have used and recommended privatefirewall and never noticed this issue before -- but I haven't run it in a while due to the issue it has with virtualbox, a necessity for me.

I can load a new XP VM with privatefirewall and dM and wait to see your config and I'll do some testing then.
Author of d7x and other PC technician's tools. http://www.d7xTech.com

Image
User avatar
Nick
Site Admin
 
Posts: 2742
Joined: Mon Nov 19, 2012 7:54 pm

Re: bug or conflict with privatefirewall

Postby refugi0 » Mon Jul 07, 2014 9:48 pm

yes, I like pf, and it get high marks at few places I've seen it tested. I could print the screen but I can tell you exactly what dm was checking when this happened and I think this was either the 2d or 3d time this "disconnection" has happened.
dm was running the first 5 delete items
Clear Print Queue
Delete Temp Files
Delete Temp Internet Files
Delete Internet History
Delete Cookies
& show cancel maintenance prompt

the system error logs show that 1 second after dmservice closed or stopped, some interaction with pf followed by several items that that totally disconnected the WAN requiring a reboot to reset. Let me know if you read this error mgs with more insight than I have, hope I'm not pointing finger at wrong culprit. the item TAP-Win32 Adapter V9 refers IIRC to proxy app I sometimes run proXPN (which IIRC recommended by GRC Gibson). So maybe I see this intermittently as it happened when I was running proXPN, and if that is the problem, that is easy to close before I run dm...???

control panel | admin | event viewer | system
Event Type: Information
Event Source: Service Control Manager
Event Category: None
Event ID: 7036
Date: 7/5/2014
Time: 20:07:09
User: N/A
Computer: XP
Description:
The dMaintenance Service service entered the running state.
For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
..
Event Type: Information
Event Source: Service Control Manager
Event Category: None
Event ID: 7036
Date: 7/5/2014
Time: 20:07:09
User: N/A
Computer: XP
Description:
The dMaintenance Service service entered the stopped state.
For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
..
Event Type: Error
Event Source: PlugPlayManager
Event Category: None
Event ID: 12
Date: 7/5/2014
Time: 20:07:10
User: N/A
Computer: XP
Description:
The device 'TAP-Win32 Adapter V9 - Privacyware Filter Miniport'
(Root\PWIPF6MP\0000) disappeared from the system without first being prepared for removal.
For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 00 00 00 00 ....
..so
this appears to be a sometimes "conflict" between dmaintenance & pf...?
also
Event Type: Error
Event Source: PlugPlayManager
Event Category: None
Event ID: 12
Date: 7/5/2014
Time: 20:07:11
User: N/A
Computer: XP
Description:
The device 'Cisco AnyConnect VPN Virtual Miniport Adapter for
Windows - Privacyware Filter Miniport' (Root\PWIPF6MP\0001) disappeared from the system
without first being prepared for removal.
For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 00 00 00 00 ....
..and
Event Type: Error
Event Source: PlugPlayManager
Event Category: None
Event ID: 12
Date: 7/5/2014
Time: 20:07:11
User: N/A
Computer: XP
Description:
The device 'Broadcom NetXtreme 57xx Gigabit Controller - Privacyware Filter Miniport'
(Root\PWIPF6MP\0002) disappeared from the system without first being prepared for removal.
For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 00 00 00 00 ....
..and
Event Type: Information
Event Source: BROWSER
Event Category: None
Event ID: 8033
Date: 7/5/2014
Time: 20:07:11
User: N/A
Computer: XP
Description:
The browser has forced an election on network
\Device\NetBT_Tcpip_{80465013-0D26-4544-A936-4277FD4F28C8} because a master browser was stopped.
For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
..and
Event Type: Error
Event Source: PlugPlayManager
Event Category: None
Event ID: 12
Date: 7/5/2014
Time: 20:07:11
User: N/A
Computer: XP
Description:
The device 'WAN Miniport (IP) - Privacyware Filter Miniport'
(Root\PWIPF6MP\0003) disappeared from the system without first being prepared for removal.
For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 00 00 00 00 ....
***
***
the pfsvc (privatefirewall) shows as running so
stopped pfsvc & restarted then reopen pfgui then
services | network connections | stopped & restarted
..but
all of the above did not restart the WAN connectio :(

reboot fixed connection aok :)

you know what I know, and I'm sure much more than I do from reading the above.

Thanks for looking at this!
refugi0
 
Posts: 25
Joined: Sat Jan 04, 2014 5:31 pm

Re: bug or conflict with privatefirewall

Postby refugi0 » Tue Jul 08, 2014 10:04 pm

quick reply, I just ran dm3.1 same as above but proXPN was not running, and dm behaved aok so even stronger suspicion that all of the above was caused by dm causing a disconnect (somehow) between pf & proXPN. Seems like peculiar to this xp so I would not worry about it. I just disable that proxy before I run dm.
refugi0
 
Posts: 25
Joined: Sat Jan 04, 2014 5:31 pm

Re: bug or conflict with privatefirewall

Postby refugi0 » Mon Jul 14, 2014 8:30 pm

followup quick reply fwiw, proxpn proxy was running and I ran ccleaner today, and it also broke the internet connection here, so that problem disconnection was not unique to dm, but seems to be unique to proxpn proxy app.
refugi0
 
Posts: 25
Joined: Sat Jan 04, 2014 5:31 pm

Re: bug or conflict with privatefirewall

Postby Nick » Mon Jul 21, 2014 7:23 am

dumb question -- do you have dM configured to clear proxy settings during maintenance? ;)
Author of d7x and other PC technician's tools. http://www.d7xTech.com

Image
User avatar
Nick
Site Admin
 
Posts: 2742
Joined: Mon Nov 19, 2012 7:54 pm

Re: bug or conflict with privatefirewall

Postby refugi0 » Mon Jul 28, 2014 1:20 am

sorry for the delay in responding. Answer "No" I have never checked the box to Clear Proxy Settings. some anomaly with how proXPN sets up when it connects. dm (ccleaner & bleachbit) all run ok when proXPN is not running. Unless you want me to test something to get reportable results, it's now a non-issue for me.
refugi0
 
Posts: 25
Joined: Sat Jan 04, 2014 5:31 pm


Return to dMaintenance Home Edition